Ticket #133 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Error documenting 5.01.02 Server

Reported by: ljlongwing Owned by: jls17
Priority: major Milestone: 3.1.1
Version: 3.1.0 Beta Keywords:
Cc: Blocked By:
Blocking:

Description

I recently came into ownership of an old 5.1.2 server that is having trouble with form documentation. I ran the tool through with -v and it doesn't provide any more details. It loads everything before Forms with no problem. There is nothing either in std out or in error out regarding what is happening.

Problem signature:

Problem Event Name: APPCRASH
Application Name: ARInside.exe
Application Version: 0.0.0.0
Application Timestamp: 534c0666
Fault Module Name: MSVCR90.dll
Fault Module Version: 9.0.30729.6161
Fault Module Timestamp: 4dace4e7
Exception Code: c0000005
Exception Offset: 000000000001e3f0
OS Version: 6.1.7601.2.1.0.272.7
Locale ID: 1033
Additional Information 1: d4a7
Additional Information 2: d4a7c6ad18071ebfbd4d9a3955f8444a
Additional Information 3: ccf9
Additional Information 4: ccf99504a17eef0bf3b283ddbe380f18

Read our privacy statement online:

http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:

C:\Windows\system32\en-US\erofflps.txt

Change History

comment:1 Changed 4 years ago by ljlongwing

I then tried exporting the entire server to XML and got the error

Incorrect format for a diary field

on 4 of the forms. Upon export of the forms in def format, I encountered that all 4 forms had a 'mal formed' change diary. Notepad++ showed me that the 'typical format' for a change diary is

numericalTimestamp(EOT)loginID(EOT)whatever you want(SOH)more stuff(ETX)

where the (SOH) is an enter character in the diary, and the (ETX) is the end of entry

well, what I found on the 4 forms that wouldn't export to XML, field 1 on each of them had a series of (ETX) back to back...

in this version of Remedy, you can't import a form on top of itself without loosing the data in the form....but luckily one of the forms was a view form...so I fixed it in def form, and re-imported it and verified that it now exports to xml just fine....

so, these other 3 forms (regular forms) all have a malformed change history definition which is causing me not to be able to export them to XML

So, I created an exclusion list of those 3 forms left, and I'm still getting a crash...but I know it's not caused by this particular problem :)....but I would love if this problem could be fixed so I could document those forms.

I even tried exporting all other objects (the ones I could) to XML, and using that as an input file, but it bombed with

XSLT Warning: Fatal Error.Occurred at unknown file, line 1, column 470. (line 1, column 470.)

Fatal Error.Occurred at unknown file, line 1, column 1.

Fatal Error.Occurred at unknown file, line 1, column 1.

Fatal Error.Occurred at unknown file, line 1, column 1.

Fatal Error.Occurred at unknown file, line 1, column 1.

Any/All? help would be appreciated

comment:2 Changed 3 years ago by jls17

  • Owner set to jls17
  • Status changed from new to accepted

comment:3 Changed 3 years ago by jls17

  • Milestone set to 3.1.1

Added some support in r549, but the slow object loading option must be specified (--slow at cmd line). This works for now.

Slow object loading is needed, because some (ARGetMultiple...) API-function aren't supported in 5.x. ARInside could detect this automatically and switch accordingly. Needs some more work.

comment:4 Changed 3 years ago by jls17

Did some more research. Only a few ARGetMultiple-API-calls are implemented in ARS 5.x (even if they are all declared in arextern.h) .. according to the C-API documentation the implementation is finished in ARS6.3. So ARInside should switch to slow object loading as soon as the server version is below 6.3. There seem to be some compatibility issues as well (e.g. archive and audit structs aren't returned by the ARGetMultipleSchema calls, but the ARGetSchema call does return them correctly). So might be better to don't use them at all on server versions below 6.3.

Only the following ARGetMultiple-calls used by ARInside are available in ARS 5.x:

  • ARGetMultipleActiveLinks
  • ARGetMultipleFields
  • ARGetMultipleSchemas

comment:5 Changed 3 years ago by jls17

  • Status changed from accepted to closed
  • Resolution set to fixed

With r623 ARInside switches to slow object loading automatically in case server version is below 6.3. That's it for now.

Note: See TracTickets for help on using tickets.